Software support

It is interesting to notice what happens when things go horribly wrong with your computer. I have a Windows system at home and a dual-boot laptop. Over the weekend I installed SUSE 10.1 on the laptop, and I have to say that this is the best Linux release yet. Fast installation, seamless and easy-to-follow instructions, and for the first time in my experience, everything works out of the box (well, almost everything, you still need to implement DVD support for legal reasons). I had several questions about installing and running certain components, but I was able to find answers in the online documentation and in the impressive network of online forums where knowledgeable Linux users will provide friendly advice and suggestions.

Contrast that experience with what happened yesterday when I tried to re-install Windows XP. The Windows machine has been giving me some problems for the last month, so I decided to reformat and reinstall. This is pretty straightforward process most of the time, as Files and Settings Transfer usually allows me to hit the ground running after an installation. Big mistake. I made copies of my files and settings and saved them into my iPod (yet another great use for the trusty player), and I encountered my first support problem. My first chore was to generate a bootable CD of Windows XP SP2 to make installation cleaner and to have a native SP2 system instead of an update. This can be done supposedly by following instructions from Microsoft’s TechNet, but their articles were incomplete, and they left you hanging at the worst time. In the end I had to use a third party application to build the CD.

After this, I reinstalled Windows, when I discovered to my horror that Files and Settings Transfer would not work! There are several problems with the application, and some patches from Microsoft, but the instructions in TechNet were completely misleading, and they ignored what I found online to be a huge problem. Several forums had a lot of users with the same problem. What to do then? I browsed and the first thing that struck me was the different level of user support offered in Windows forums. A lot of users were rude, and their suggestions were not that useful, sometimes even condescending. Needless to say, Microsoft’s own solutions were useless.

After several hours of browsing and beating my head against the wall, I found an obscure reference to the fact that this could be caused by files being Read Only. I went into the Windows Command Prompt and used “attrib” to get rid of the protection. It worked! How hard is it for Microsoft’s support to write a small article with this short and useful information?

Anyway, after reinstalling the files and settings, my computer started behaving exactly as before. I am guessing that there is something wrong with the Windows settings transferred into the new Registry, as the system worked perfectly before installing the settings. I am now unto the 2nd installation, with almost no sleep, hoping that the system will be ready some time in the future.

By the way, I’m writing this from Linux.

Leave a Reply